Function and Variable Naming

Conkeror uses snake_case for variable and function names. That means they are lower case with words separated by underscores. By contrast, the Mozilla codebase uses camelCase style. This difference makes it easy to tell at a glance whether a given identifier is part of Conkeror or part of the underlying Mozilla platform. We also find the underscore style easier to read.

If the identifier is part of a module, it should begin with the name of the module. Abbreviate sparingly --- abbreviations in identifier names don't really make anyone's life easier.

Note that exceptions to this guideline can be found in the Conkeror source, but only for historical reasons. All new identifiers should follow this guideline for style.